DEMO 03 Baseline Forecast  showing zero's for FY21

MaheshKosuri
Occasional Contributor

DEMO 03 Baseline Forecast  showing zero's for FY21

 

DEMO03 Baseline Forecast module showing zero's for FY21

I have used four more formula's along with the shown in this image. 

Formula 1 : IF 'SYS01 Time Settings By Week'.'1st Forecast Year?' then OFFSET('DAT03 Historic Volumes'.Volumes, -52, 0) else IF 'SYS01 Time Settings By Week'.'2nd Forecast Year?' then OFFSET(Default Forecast , -52, 0) ELSE 0

Formula 2: IF 'SYS01 Time Settings By Week'.'1st Forecast Year?' then OFFSET('DAT03 Historic Volumes'.Volumes, -52, 0) else IF 'SYS01 Time Settings By Week'.'2nd Forecast Year?' then  LAG(Default Forecast , 52, 0, STRICT) ELSE 0

Formula 3: IF 'SYS01 Time Settings By Week'.'1st Forecast Year?' then OFFSET('DAT03 Historic Volumes'.Volumes, -52, 0) else IF 'SYS01 Time Settings By Week'.'2nd Forecast Year?' then OFFSET(Default Forecast , -52, 0) ELSE 0

Formula 4: IF 'SYS01 Time Settings By Week'.'1st Forecast Year?' then OFFSET('DAT03 Historic Volumes'.Volumes, -52, 0)
else IF 'SYS01 Time Settings By Week'.'2nd Forecast Year?' then OFFSET('DAT03 Historic Volumes'.Volumes, -52, 0) *OFFSET(Growth Rate%, -52,0) ELSE 0

 

My understanding is FY21 values should be Default forecast values  of FY20 but these values are calculated after the first line item  i.e baseline forecast. How can we derive these values? 

Appreciate your help.

 

MaheshKosuri_0-1616085667407.png

 

1 ACCEPTED SOLUTION

Accepted Solutions
JaredDolich
Moderator

Re: DEMO 03 Baseline Forecast  showing zero's for FY21

@MaheshKosuri 

Sorry for the late reply. 

The next step is to work your way backwards on that formula. Since you're getting the 2020 data but not 2021, I suspect it's your default forecast - you've got a subsidiary view on those line items. Make sure all the line items are using the "applies to" dimension. The forecast on that uses the baseline forecast times a growth rate. Can you make sure both of those values are populating? I can't remember when the growth rates are provided so you may have to enter a few temporarily to see the values show up. Here's what it should look like. I moved it to the same position you had above.

DEM03_001.png


Jared Dolich

View solution in original post

3 REPLIES 3
JaredDolich
Moderator

Re: DEMO 03 Baseline Forecast  showing zero's for FY21

@MaheshKosuri 

The correct formula is:

IF 'SYS01 Time Settings By Week'.'1st Forecast Year?' THEN 'DAT03 Historic Volumes'.'Offset Volumes for 1st Forecast Year' ELSE OFFSET(Default Forecast, -52, 0)

Let's break that down:

  • Our objective is to "seed" unelapsed periods with LY history in the first year and then use the first year to seed the second year.
  • First, we need to determine what year we are in. You got that part no problem.
  • If we are in the first year then let's go ahead and bring our historic volume data which we already Offset in DAT03.
  • Otherwise, we must be in second year so lets just grab the volumes from the first year by using OFFSET.

You were so, incredibly close. Hope this helps.

 


Jared Dolich
MaheshKosuri
Occasional Contributor

Re: DEMO 03 Baseline Forecast  showing zero's for FY21

@JaredDolich 

 

Thanks Jared,
I have used this formula already but no luck. 

Just for my understanding , all line items will be generated first for each time period here ?  or each line item will be generated for all time periods frist ? How this calculation engine works?

 

MaheshKosuri_0-1616088915700.png

 

JaredDolich
Moderator

Re: DEMO 03 Baseline Forecast  showing zero's for FY21

@MaheshKosuri 

Sorry for the late reply. 

The next step is to work your way backwards on that formula. Since you're getting the 2020 data but not 2021, I suspect it's your default forecast - you've got a subsidiary view on those line items. Make sure all the line items are using the "applies to" dimension. The forecast on that uses the baseline forecast times a growth rate. Can you make sure both of those values are populating? I can't remember when the growth rates are provided so you may have to enter a few temporarily to see the values show up. Here's what it should look like. I moved it to the same position you had above.

DEM03_001.png


Jared Dolich

View solution in original post