Data Import

Highlighted
Occasional Contributor

Data Import

Hey I am having trouble with level 1 importing employee data in syso8 it says the following:

Import into SYS08 Employee Details module failed: The column headers in the file you are attempting to import do not match the import definition.
1 Line Item identifier(s) ("Active?") were not mapped and ignored

Code111 FailedDepartment111 FailedCountry111 FailedLeave Date14 FailedCurrent Salary111 FailedCommission %111 Failed

Can anyone help?

8 REPLIES 8
Highlighted
Master Anaplanner/Community Boss

Re: Data Import

Hi @KMc,

 

Can your share the mapping screenshot to check this.

 

Mostly your Employee mapping is incorrect, make sure you mapped employee code to #E2 Employee.

We should not map Name to Number list, the number list can be identified/mapped through code only, so we need to map code with the list.

Pls check your mapping.

~Vignesh  M

Highlighted
Occasional Contributor

Re: Data Import

@KMc 

 

Looks like your import mapping is wrong. Can you please show the mapping

 

RM

Highlighted
Occasional Contributor

Re: Data Import

Hey thanks for the help here is the picture2020-03-26.png

Highlighted
Master Anaplanner/Community Boss

Re: Data Import

Hi @KMc,

 

The start date is something that will not change over time. For example, Employee Salary and Sales change/differ overtime but the start date of an employee won't.

 

The system Emp module should contain only the #E2 Employee dimension, no Time dimension. So remove time from the dimension and add Start date as a line item and map it.

 

~Vignesh M

Highlighted
Occasional Contributor

Re: Data Import

Hey, I did what you recommended but I am still accounting the same problem.  I think it might have to do with the active section.  Please let me know what I should do.

Highlighted
Master Anaplanner/Community Boss

Re: Data Import

Hi,

Make sure you removed time dimension from all the line items of SYS EMP module and try the import.

 

If you removed time dimension, then you should see only 2 mapping in the import.

1. #E2 Employees

2. LINE ITEM

 

If you are still facing the issue, post the screenshot of the mapping, module blueprint view.

 

~Vignesh M

Highlighted
Occasional Contributor

Re: Data Import

2020-03-26 (4).png2020-03-26 (5).png

Highlighted
Master Anaplanner/Community Boss

Re: Data Import

@KMc 

 

Can you go to Size list and see if the list is updated. It looks like that it is not updated. Once you update the Size list with its list items then rerun the action again.

 

Hope that helps

Misbah