Filter Crash in Production

Highlighted
Occasional Contributor

Filter Crash in Production

Hi,

 

I have created a Time filter for a Dashboard and Export view in Dev Model. But when i push that to Production every time the Filter gets crashed in the Saved view, so i am not able to get the desired layout in the Dashboard and Export File. Can you let me know where am i going wrong.

 

Attaching the screenshot from Dev model which says the layout i want in Production and the Layout gets disturbed in Production where the saved view in not keeping the filter.

 

Thanks.

6 REPLIES 6
Community Boss

Re: Filter Crash in Production

if it works in DEV and not in prod it means you are basing this filter on a list item that doesn't exist in production.

 

ps: your screenshots do not show the filter settings, would be useful


Nathan Rudman, Anaplan Model Builder
Highlighted
Occasional Contributor

Re: Filter Crash in Production

Hi@nathan_rudman ,

 

I have a Selection Module without any dimensions where the end user will add the month he wish to view the data for and export from Anaplan.

 

That line item in selection module is used as a filter in my spoke modules to display the data. Below Boolean formula is created in module to filter data:

Selection Module.Month = ITEM(Time)

 

time.PNG

 

and then that filter is used in the saved view 

 

filter saved.PNG

 

Do I need to change any logic ?

Highlighted
Community Boss

Re: Filter Crash in Production

you can see the filter is based on "L3 cost centre mapping" list.
I'm sure this item doesn't exist in production.

 

And that's probably because Filter: Month has the L3 dimension, which it doesn't require.

You should centralize your time filters in one system module, that would avoid this issue.


Nathan Rudman, Anaplan Model Builder
Highlighted
Occasional Contributor

Re: Filter Crash in Production

The list is present in Production model. That is the dimension of the module where that filter needs to be applied. Also the Boolean line item is returning the true when the condition is true but not getting picked in the saved view.

prod.PNG

Highlighted
Occasional Contributor

Re: Filter Crash in Production

@nathan_rudman  Created a new Time Module and used the line items from that modules as a filter and post that this issue got fixed.

 

Thank you 🙂

Highlighted
Community Boss

Re: Filter Crash in Production

if you can accept my answer as solution it would be great !

ps: take a look at this app, there's a lot of useful time filters there
https://community.anaplan.com/t5/learning/Time-Filters/ba-p/28086

Nathan Rudman, Anaplan Model Builder