Formulas in lesson 6 not working

Efuacudjoe
Occasional Contributor

Formulas in lesson 6 not working

@noelle_murphy Hi, can I set up a 1:1 with you? Some of my formulas in lesson 6 aren’t working & it’s hard to move on from that. I also sent you an email. Thank you

1 ACCEPTED SOLUTION

Accepted Solutions
anand.shekhawat
Valued Contributor

Re: Formulas in lesson 6 not working

@Efuacudjoe 

 Yes the formula is correct. Just set the summary to 'Any'. You will get your output correct

 

~Anand

View solution in original post

10 REPLIES 10
anand.shekhawat
Valued Contributor

Re: Formulas in lesson 6 not working

@Efuacudjoe 

 

You can post the question here as well if you want.

 

~Anand

Efuacudjoe
Occasional Contributor

Re: Formulas in lesson 6 not working

@anand.shekhawat Thank you.

 

For activity 6.6.2 this is what im getting but its different from the screenshot.

 

Also,

Im not getting the FY20 & FY21 boxes to be checked off.

Efuacudjoe_0-1641463386295.png

Efuacudjoe_0-1641463471397.png

 

its hard moving on in the course without getting these done.

 

 

anand.shekhawat
Valued Contributor

Re: Formulas in lesson 6 not working

@Efuacudjoe 

 

Please check the formula of Forecast Period? line item in the SYS00 Time settings Module. The formula should be written in such a way that the boolean is checked for all the forecast months Also make sure you have set the Current Period correctly in the time settings. You can find the Time settings on the top left in Model Settings panel.

 

I hope it helps

 

~Anand

Efuacudjoe
Occasional Contributor

Re: Formulas in lesson 6 not working

@anand.shekhawat 

These are all done properly, please see attached images.

Is there anything else I need to try?

 

 

anand.shekhawat
Valued Contributor

Re: Formulas in lesson 6 not working

@Efuacudjoe 

Both the screenshots look good. Yes, you need to check one more bit.

 

Kindly navigate to SYS00 Time settings Module and check if you have written a correct formula for 'Forecast Period?' line item.

 

~Anand

Efuacudjoe
Occasional Contributor

Re: Formulas in lesson 6 not working

@anand.shekhawat 

This should be the right formula right?

anand.shekhawat
Valued Contributor

Re: Formulas in lesson 6 not working

@Efuacudjoe 

 Yes the formula is correct. Just set the summary to 'Any'. You will get your output correct

 

~Anand

Efuacudjoe
Occasional Contributor

Re: Formulas in lesson 6 not working

@anand.shekhawat Thank you so much. It finally worked. But Can you pls explain the logic behind that? Why did summary need to be set to 'Any'?

anand.shekhawat
Valued Contributor

Re: Formulas in lesson 6 not working

@Efuacudjoe 

Yes so the logic here is,

By using the formula - 'SYS00 Time Settings'.Forecast Period?  you are pulling the Yearly data of 'Forecast Period?' line item. Why Yearly ? It's because the SYS01 Module is Time dimensioned and the Time Scale is set to Year. That is why if the summary was set to None in the earlier case, your booleans for the summary items(FY) were all blank. After setting it to 'Any' the booleans of FY in your SYS00 Module got checked in case any of the months of that particular year is 'True'.

 

I hope it helps.

 

~Anand