Import Action Into List from Saved View is not importing all values (no failures/ignores/duplicates)

jonathan.edwards
Certified Master Anaplanner

Import Action Into List from Saved View is not importing all values (no failures/ignores/duplicates)

Hi,

 

I've setup an import action from a saved view to a list in a different model & workspace. It imports without any failures or ignores, but it does not import all of the items. Why is it not importing all items & how do I change the view and/or import action to fix it?

 

Source (Data Anonymized):

  • 3 dimensions pivoted to rows
  • Time & Version as page selectors
  • Actual version is hidden
  • Reporting Key & 01 Gross fields are not dimensionalized by version
  • 2 filters
  • 1st filter on time to only show forecast periods
  • 2nd filter on 3 row dimensions to only show rows that have non-zero dataCapture.PNG

Capture.PNG

 

 

Destination: The Reporting Key is first imported into the name of a non-numbered list. Then the data is imported into a module only dimensionalized by that Reporting Key as seen below.

Capture.PNGHere is the problem: Only 3 of the 9 entries imported into the List & then into the Module. How do I fix it so that all 9 entries import?

 

The import actions do not error. There are no ignored entries, no duplicate entries, and no failed entries.

 

I've tried the below solutions without success. 

  • User Access: I tried checking my user access since it looks like only Season B imported. I have access to all seasons & products. Also, in other months, Season A does import.
  • List Character Limit: I manually added the 6 keys that were not imported successfully. Therefore I do not believe it is a list character limit issue.
  • Dimensionality issue: The reporting key is not dimensionalized by version. I tried dimensionalized it by version, but it did not change anything.
  • Pivoting error: I know that often import issues arise when all dimensions are not pivoted to rows. However there is a limit of 3 dimensions on the rows (silly rule). Additionally, I do not believe it is a pivoting issue because the time period import fine (as a page selector) but of the rows shown, some do not import.

Thank you for your help! It seems like the saved view filters to show 9 items, but then it filters to show only 3 items when the import action runs... but why? I appreciate any and all help!

 

Jonathan

 

4 REPLIES 4
einas.ibrahim
Master Anaplanner/Community Boss

Hi @jonathan.edwards 

 

Can you specify if all 9 keys are imported to the list but the module only displays 3 keys OR only 3 keys are imported to the list??

 

-Einas

Einas
"Give a Man a Fish, and You Feed Him for a Day. Teach a Man To Fish, and You Feed Him for a Lifetime"
MaartenGijbels
Regular Contributor

Hi Jonathan,

 

It's an answer from the gut, but a mistake most people make when importing from saved view is related to filters.

 

If you have a filter on it it will only import the values filtered for that selection of page selectors. For every combination of page selectors. That's a bit abstract. But try this:

 

Page Selector:

Country: US

(Other values: Canada)

 

                Sales

BU1            1000

BU2                  0

 

 

If you add a filter here to remove blanks only BU1 will remain. So if there is a value in BU2 for Canada this won't be imported.

 

It's not necessarily a solution, but it's the most obvious solution based on the information provided.

 

Actions to take:

- remove filters

OR

- adjust filters to check for all values of the selectors

 

And reach out in case it's still not working!

 

All the best,

 

 

 

 

 

otalpur
Certified Master Anaplanner

Similar to what Maarten said, I would open up the saved view and check the filter on the saved view.

You mentioned that the saved view filter shows 9 rows. Is this action part of a larger process? Is it possible that the filter has logic which is dependent on earlier logic which is adjusting which is being shown?

 

If it is not a filtering issue, it could possibly still be a issue with versions? Are all versions populated equally in your source model? 

MaartenGijbels
Regular Contributor

I quickly checked and created an improvement idea for this. Honestly, it should have been there years ago..

 

Please support the idea to get it on the roadmap.