Remove space/indentation from list items when parent levels are hidden on UX worksheet

Remove space/indentation from list items when parent levels are hidden on UX worksheet

When parent levels are hidden on worksheet, there are a lot of white space for list items which is a big waste and also not good visualization. See screenshot below. It'd be great if the space will be shortened or removed when one or more parent levels are hidden/deselected.

 

Screenshot 2020-10-13 at 4.18.07 PM.png

 

 

7 Comments
AWhitworth
Certified Master Anaplanner

Great idea, it could also be useful to give an option to remove the indentation always but highlight the parent in another way. Perhaps by bolding or adding options for the user to set this as they want. 

tscott
Certified Master Anaplanner

if you are using a line item subset it can get even worse... If anyone knows a sensible (i.e. not creating individual line items) workaround for this I'd love to hear it.

 

It looks awful with this excessive indentation: 

tscott_0-1614856726778.png

 

DelahayeOlivier
Contributor

Up !

 

It is particulary disturbing when you have several levels but only show leaf items.

Users don't understand why so much empty space on the left.

Bhaidani1
Occasional Contributor

I agree that this is something that should be looked at to be implemented in the future 

RobertPhilcox
New Contributor

Bump.

 

Regularly have clients looking for this. 

bantiatwork
New Contributor

This is really making grids take lot of space on left without any reason from user perspective. There should be a way to remove space.

AndrewS
New Contributor

Agree with all above this would be a great feature.

 

There is an odd work around for this issue. If you apply a Sort to a column in the UX grid it will push all the list items over to the left side. Can't say I understand why, however one of the UX grids I have a list dimension down to the lowest level as the first column/ row list and the related line items in the columns. When I apply a sort to any of the columns the list display name becomes left aligned. 

 

You can't see this impact in the designer mode however as sort options are not available.

 

Hopefully we get a proper fix soon,

Andrew