Import Rejection Limitation?


Hi Community! One of my clients asked me a question I wasn't sure about. Thought I'd ask here.

Using AnaplanConnect does anyone know of a limitation of how many rows can be rejected before the entire action is rejected?

I'm not aware of any limit but wanted to see if I missed something.

Adding Pros @DaanishSoomar @MarkWarren @ben_speight @rob_marshall 

Best Answers

  • DaanishSoomar

    I see @JaredDolich

    What I would do here is:


    1) With you by their side, have the client log into Anaplan. Open the model. Run the action or process that is of interest. See what happens in the manual run. Does the data load properly?


    If no, then herein lies the issue. The below info on encoding might apply as well, but I would double check first to see if the action is mapped and setup correctly. 


    If the data runs manually, and it’s only an Anaplan connect issue, then I would begin to explore the import menu with the encoding options. There are some issues with regards to UTF-8 vs UTF-16 in certain versions of Anaplan Connect where there are issues of files not loading correctly or having issues with  special characters. 

    The latest version of Anaplan Connect is better at encoding since the dev team has addressed those bugs in the latest release. I had a client with a similar issue and downloading the latest version solved the issue. 


    Here are some articles that might be good to look at:



  • ben_speight
    Answer ✓

    There is a limit to the size of an error dump file - 50000 rows. But when this is hit, the importer hasn't given up importing, but reporting individual errors to the dump file (so the summary of errors should remain accurate).


  • Hmm @JaredDolich,


    This is an interesting question. 

    Some clarifying questions:


    1) When they run the action manually, are there error messages? If so, Anaplan Connect is simply automating what happens in the manual environment through its own interface. 

    So in practice the result should be the same for what happens in the manual run. 

    I am not aware of any limit either.

    However, depending on the size of the file, there are some chunking related issues where if the file is large, the import might get halted halfway through or something like that. You will need to raise the chunksize. 

    Loading the file in chunks can help improve the load times. Here’s an article that breaks down the details.

  • @DaanishSoomar 

    Yeah. The client has not tried to load manually. Only through Anaplan Connect. The files are extremely small, no more than 10 rows. Seems it allows one record rejection but more than one it fails the entire action. My hunch was that it was a formatting issue and unfortunately the client didn't save the files so I can't validate. We were just curious if anyone knew of a limitation because ultimately, the import will be closer to 150,000 rows. Thus, the concern.

  • @DaanishSoomar 

    Thank you! We'll give that a try.

  • No problem @JaredDolich!

  • Great insight @ben_speight