not a recognized line item


We are repeatedly getting the not recognized line item error when building out simple formulas sing line items all contained within the same module. In the screenshot below A-3 references A-1 + A-2 and all are clearly line items, this is happening when selecting the lines items with the formula editor and typing out the names manually.


The workaround found has been to rename the line item to a shorter name, build the formula and then change the line item name back. This solves the problem but is not sustainable. 


Has anyone encountered this issue before and found a solution? 


  • Misbah



    I too have faced similar issues in the past but it was only when i tried to refer the line items from diff module. For me manually typing line items worked. But yeah New MX has a few bugs which are not yet fixed, I think this one is still out there



    Miz Logix

  • @Misbah 


    Thanks, it definitely feels like a bug. I will log a ticket with support and see if they can provide a resolution. 

  • @AWhitworth Anaplan item names work with ASCII codes.

    There are ASCII codes that are not visible. 

    It is also possible that the Line-item was created with some copy/paste and can contain this kind of strange non-visible character.

    The solution is indeed to try to rename the line-item and manually rename it back.. this should solve the issue. 


    Below is an example of a line-item that seems to be "blank"...however it contains the ASCII code 226 character.

    The ASCII code for space is 32 and a line-item cannot be defined as BLANK space as a name. 






     Hope it helps




  • Thanks for the explanation @alexpavel  I did think it must be something invisible like this.


    It is however still showing some odd behaviours. In the below example I have performed the rename trick for A-1 to get the formula working in A-2, but then repeating the formula (a direct reference to  A-1) in A-3 throws up the error again.


    The formula is working presumably with ASCII  characters present for A-2. I would expect an error to occur when we renamed A-1 back if ASCII were present again. 






  • Indeed quite strange behavior. 

    What browser are you using?


    You could try to use simple names like a, b, c for the line-items, build all the necessary formulas and then rename them with final names. 


  • Using Chrome, it is also happening to multiple users. 


    the renaming is the best option but it's a large module and quite time consuming,unfortunately. We have lodged a ticket for support as would like an explanation to prevent us accidentally doing it again