In L1 Model Building activity 5, There is an error when updating the Bonus formula in EMP02.




Can someone help me where am I going wrong. As the error is data type mismatch. Please find below screenshot. 



Thanks in Advance.


  • @Tejaswari001 

    Most likely the "Role" line item. In order to use SUM and LOOKUP the line item must be formatted as a list. I suspect role is formatted as text. See if that helps. If not, lets see the SYS08 blueprint. You got this!

  • @JaredDolich 




    Thank You. Yes, Role is formatted as text. Now, I have changed to List as advised.


    After the Formula Update, i could see that the Bonus is showing as 0.


    Before updating the formula:





    After Updating the formula: Bonus is 0



  • @Tejaswari001 

    make sure your EMP03 Bonus % Line item is loaded. Looks like you're multiplying the salary times zero.

  • @JaredDolich 


    EMP03 Bonus % is loaded. All the 4 line items after updating the formula is showing as 0.



    Formulas used are:


    IF Employed? THEN Salary * 'EMP03 Employee Drivers by Role'.Bonus %[LOOKUP: 'SYS08 Employee Details'.Role, LOOKUP: 'SYS08 Employee Details'.Depatment] ELSE 0


     IF Employed? THEN 'EMP03 Employee Drivers by Role'.Car Allowance[LOOKUP: 'SYS08 Employee Details'.Department, LOOKUP: 'SYS08 Employee Details'.Role] ELSE 0


    IF Employed? THEN 'EMP03 Employee Drivers by Role'.Phone Allowance[LOOKUP: 'SYS08 Employee Details'.Department, LOOKUP: 'SYS08 Employee Details'.Role] ELSE 0



    Can you suggest.




  • @Tejaswari001 

    OK! We're getting close now. Let's take a look at SYS08 and make sure both the role and the department are loaded for each employee!

  • @JaredDolich 


    Sure. Please find below.



  • @Tejaswari001 

    And look at that! Bonus is loading. Haha, good job.

  • @JaredDolich 


    Yes, it is. Not sure how it is working suddenly. Can you have a look at below screenshot.



    May i know where am i going wrong.




  • @Tejaswari001 

    Misspelled word - Medical Benefits. Instead of typing in the line item, click on it instead. That way if there are any hidden characters, Anaplan will pick it up.

  • @JaredDolich 


    Ahh, Just Realized. And yes, it worked now. Thanks a ton for helping me. As being a beginner, Need such supporting hand so that i can learn and never commit these mistakes again. 


    Can you check if the below is correct to proceed further.




  • @Tejaswari001 

    Woo Hoo! Nice work. That's the hardest part of this course. You're almost done. Go ahead and mark this solved if you're satisfied. Way to go!

  • @JaredDolich 


    Can you help me for below. As i can see data mismatch. in SYS08 Role is formatted as list. Where would i  have done a mistake.



    So i tried formatting the Region now. Formatted to List and Geo Hierarchy as G1 Region. But could see below error.



    Can you suggest. Thanks In Advance.

  • @JaredDolich 


    I have Tried the formula, 

    'EMP02 Employee Expenses'. Salary[SUM: 'SYS08 Employee Details'. Region, SUM: 'SYS08 Employee Details'. Role]

    and for all the line items. But the result is still 0.


    Please find below screenshots.





    EMP02 :







    Can you suggest. Thanks in Advance.


  • @Tejaswari001 

    Ah ha! by default, Anaplan will set the calendar to months or weeks depending on your calendar. In this case you need it to be years. Set the module and all the line items to Year on the "time scale".



  • @JaredDolich 


    Yes, they were set to Years before as below. But the results are 0.




  • @Tejaswari001 

    Looks like your Region line item in SYS08 isn't populating. Check that formula.

  • @JaredDolich 


    Yes Exactly. It worked now. 


    Also, This is the 3rd time i am running the Import in SYS08 as the Region is getting cleared off And need run again. And i didn't notice this time. What could be the reason for data getting cleared sometimes. Was that because of any changes i have done.

  • Is the result correct in the screenshot. Can you confirm.
  • @Tejaswari001 

    If you change the formula, and sometimes if you change the dimensions of the module this will happen. Could also be a result of a list change. Hard to say. The best strategy is to work your equations backwards. If Anaplan allows you create the formula without error then it's a good bet that the formula is correct. Something upstream must be causing the issue.

  • @JaredDolich 


    Noted. Thanks for the information.