Export Button based export filters Error


I manage a model that has export filters at the bottom of the dashboards. There are multiple dashboards. They are the same export filters; Version, year, and department.  There is also an export button to export based on the export filter selections. 

The export buttons were working a few days ago and today we are getting an error message (see the attachment). 



When I tried to run this action in the Actions tab, I am getting the 2nd screenshot. 




It seems as though the export filters are not being applied and the export is exporting all versions, years, and departments. 
Why aren't the export filters working? What can I do to get it to work and what is causing the problem?


There is a Save View for each Export button and when I export the data manually via the Save View (connected to export filters) it is working. The Export button just isn't working correctly. Why is that?


  • andrewtye
    edited November 2022

    Have you tried rebuilding the export action and/or has anything other than multicolumn (the most left option) been selected in the export action itself?

  • JussiLi
    edited November 2022

    We are facing similar problem when trying to export module data to Excel with Data | Export -command. 

    You can export smaller modules to Excel but not larger ones. 


    In my opinion this is a bug that appeared in last weekend's platform maintenance. But according to Anaplan Support and Level 3 this is "a behaviour change", which sounds like a planned removal of an essential feature. 

  • n0200309
    edited November 2022

    Thanks for the insights. Does Anaplan post what is part of their maintenance? I guess I didn't take into consideration that their weekly maintenance could have an impact.


    Yes I believe the exports with issues are all in Excel format. The export filters are not applying and it is trying to export everything, which is too much to export.  I may have to recreate the export in CSV format and hope that resolves the issue. 


  • JussiLi
    edited November 2022

    Luckily this wasn't planned change but unplanned, and Anaplan was able to fix this quickly.

    This was fixed in last weekend's (19.11.) maintenance release.