How to filter elements of a Line Item subset by user

edited June 2023 in User Experience

We can filter elements in a list,
We can filter Time elements,
We can filter Line Items using a Line Item Subset,
But can we filter items in a Line Item subset?
(All dynamically by a user)

Summary of the problem:
I use a boolean per user to filter a module sized by a line item subset. The filter worked fine until last week, but since the weekend I've had to refresh the page for it to apply. This mechanism still works well for classic modules, but not for my LISS-sized modules. Is anyone experiencing the same problem?

Details of the problem :
We have a Module_Calc in which I calculate the Forecast, Actuals in Quantity and Value, by :

  • Product,
  • Currency (EUR, USD),
  • Unit (Ton, Kg, Lb), and
  • Time,

We created a Line Item Subset_A: LIS_A, based on Module_Calc,

We created the Module_LIS based on this LIS_A, in which we have a Line Item whose formula is: collect(),

We have created a Module_Filtre_Users 'boolean' in which I tick (by formula) whether the Product value should be retrieved or not. These ticks depend on the user's choices.

We've created a Module_OUTPUT with the following dimensions:

  • Product
  • Users
  • LIS_A
    and in which we have 1 Line Item "Value : formula : IF Module_Filtre_Users[lookup: "currency & Unit" / users] THEN module_LIS ELSE 0.

We have created a Page_OUTPUT, in which we have published the user's choices in the header:

  • Different product properties,
  • A boolean which says "Show value" which should display the items of the LIS_A set as "Value" and otherwise as "Quantity".
  • the Unit
  • the currency

Then my module_OTUPUT.

  • In line: LIS_A => which I dynamically filter by users: "show value".
  • In column: Time
  • In selector: my line item

The dynamic display by user worked for a few hours.
Since then, the weekend has passed, and I've had to check the "show value" box and then "refresh" at the top left of the page.

Actions taken since :

  • republishing the module
  • reactivation of the filter
  • I can't remember everything we've tested].

Are we the only ones experiencing this kind of problem?
Is there a solution?
Can support help us?
Any other ideas?


  • @axel.frot

    I think it is a bug. Did you contact the support team? What do they say?

  • Hello KirillKuznetsov,
    Yes, seeing no return, we contacted support.

  • Hi,

    We had a similar case, I think, but it was slightly different:

    We had a requirement to have a nested set of columns in a report, including: Activity List (items), and Line Items (there are 5 line items)

    Part of the requirement was to be able to hide 4 of the 5 line items, based on a user checkbox.

    To accomplish this, we created a line item subset, and use that subset in a filtering mechanism that was tied to a User Level checkbox (to hide/show line items).

    Building a custom view in the New UX (instead of using saved module views) is preferred for us at my company. However, when we built a custom view in the new ux, it wouldn't recognize the filter. Now, it works in Anaplan Classic, but not in the new UX. We did open a case with Anaplan, and were told, I think (I forget) that its not considered a bug and won't be fixed.

    This example is different, but (from what I see) your filter should work.

    Good luck!


  • vanreign
    edited June 2023

    Hi Axel. I am curious about the upper right context selector of "Value". We know that will stay in single context. And maybe that is okay if the selector is a single item selector. I would likely start with validating that "Value" selector is the only one line item in that module. Terminology may be overlapping here where "Value" is used generically as a line item to mean either quantity of value. If not (there is a value and quantity line item), it may be an unnecessary dimension. Or I would double check where you are using the Users dimension and ensure that Show All Users: Off is selected for modules that are intended to be in single context. Generally speaking, if you are using Line Item List selectors, issues like this usually come up because a native selector is sitting in a single context with no Users dimension association and therefore would need a Page refresh to apply User filters because single context native selectors would not know of a particular User Line Item selection. I hope this helps and really do believe it can be resolved with review of items mentioned above because I've been there :(. If not, if you share the blueprint of modules, it may help better understand what is occurring. Cheers, James

  • @PaulRitner

    I understand everything.
    That sounds exactly like me.
    If Anaplan doesn't consider this a bug, then there is a bug, because it worked on Friday.

    Thanks for your help

    @James Martin (Cognizant)

    To answer in order:
    "Value" = 1 Line item. This Line Item has been renamed to "Data". It's not Quantity/Value.
    The "User list" parameter has been used, with "Show All Users: Off".

    Thanks for your help too !

    I'm expecting level 3 support very soon.
    If I'm not happy with the feedback, I'll be sure to get back to you here! :D

  • If you're not getting any result then its a bug, its better to contact support team.

    Because it was working fine few days back.



  • Hello @Bishalpilley,
    I'm still waiting for a reply from support.
    I'll bring the support answer on the forum for the community!


  • Hello @KirillKuznetsov @PaulRitner @James Martin (Cognizant) @Bishalpilley

    here's the answer from support: "filters are only setup to dynamically update when modules are dimensioned for the Users list. Your use case obviously references an alternative users list which is why the filters are not dynamically updating."

    Indeed, on rereading my first post, I realize that I've misdescribed the dimensions of the modules. We don't have "Users" but "Alt users" in order to limit the space occupied by the Model.

    this ticket has been around since 2021, and probably won't be implemented any time soon.

  • vanreign
    edited July 2023

    Hi @axel.frot, In Module_OUTPUT, you do not have Users for that whole module, right? Since there is no Inputs in the second module, the overall applies to model dimension structure does not need Users. Users is only needed in a filter line item which should not be very large. I think the Users dimension done that way could be an option that will not klLL the WS. The only other thing I thought is an mapping module between your fake Users and real Users while retaining the rest of the Alt User structure. FindItem(Alt Users, Users). Filters would just have a LOOKUP and I'm not sure but may be real-time updated since you now have the selector in single context "Show All Users: Off". Cheers, James

  • @PaulRitner Hope you're doing well my friend!

  • @vanreign Initially, I also applied filters based on Custom Users selections (Alt Users in our discussion). But, end users faced an issue that data is not updating dynamically. Then, I created a filter module with Users and a mapping line item to lookup custom users selections. Later, applied filter (dimensioned by Users and Target list) on the saved view in the target module. Now, data is updating dynamically.

  • @Vamsi_Kaki Thanks for clarifying the steps. That's great!