File Download API using name instead of ID

Hi Everyone,

I have an Anaplan ←→Azure integration pipeline where Azure Data Factory pulls some data using an export action via Anaplan APIs.

We were using the name instead of the id when we run the download API. However, today observed that it no longer works. Getting a 404 Not Found.

{    "status": {        "code": 404,        "message": "Not Found"    })

I tried running via Postman and get the same result. But if I replace the name with the ID, the API returns the data.

We had not seen this issue until now while using name in the URL.

Did anything change recently with respect to the export/download APIs (Using API v1.3) ?

Able to run below APIs using the name -

  1. Get export metadata. (<workspaceID>/models/<modelID>/exports/<exportName>/)
  2. Run export. (<workspaceID>/models/<modelID>/exports/<exportName>/tasks/)
  3. Get task status.(<workspaceID>/models/<modelID>/exports/<exportName>/tasks/<taskID>)
  4. List Files (<workspaceID>/models/<modelID>/files/)
  5. Download File - This step FAILS (<workspaceID>/models/<modelID>/files/<fileName/exportName>)