I can't create a model


Hello everyone,

I want to create a model but when i click "manage models" , the error below shows up. If anyone has faced this issue before , I need help to resolve this.

Best Regards,


Best Answers

  • ryan_kohn
    Answer ✓

    You are receiving the error message "Invalid authentication method for this workspace".

    In order to Manage Models for a workspace, you need to be a Workspace Administrator (WSA) in the selected workspace. Note that WSA is assigned on a per-workspace basis — i.e. it is possible to be a WSA in one workspace, but not another workspace. As a first step, you should validate that you have WSA priviliges in the intended workspace.

    If you know you have the correct access, then check the following:

    1. Log out and log back in to ensure your session has not timed out
    2. Ensure you are logged in with the correct "method" of authentication - either basic authentication (username/password) or SSO.
    3. Try logging in with incognito to ensure authentication cookies are not an issue

  • Vamsi_Kaki

    Hello @imadlou , since you are able to access "Manage Models", it confirms you have WSA access.

    1. Try closing all windows and re-login or
    2. Login in Incognito mode or other browsers
    3. Try login with SSO (if enabled)


  • Have you tried on other browsers?


  • @imadlou Do you get that error just by opening the "Manage Models" dialog or after you have either selected "New", "Copy" or "Import"? I have received a similar if not the same error when I tried to do a Copy or Import. But even after I get the error I find it copied/imported the model anyways. I just assumed I got the error because the models I was copying did take time to load to memory. If you're getting the error just on opening the "Manage Models" dialog I suggest you contact Anaplan Support.

  • Hello Everybody ,

    Thank you for your time to help me with my issue. It was a SSO problem and I resolved the issue.