Rounding function showing inconsistent results




We are  getting some inconsistent results with round function in Anaplan which is causing bit of an issue at a client's end . I have seen few posts relating to round function so may be a know bug . Just trying my luck if anyone has been able to solve this .


Below is an eg.


Please note how rounding formula behaves differently for Input 1 (rounds up) and Input 2(rounds Down)




Here is the blueprint 




 All line items are formatted as follows



Best Answer


  • @karank 


    What is the expected outcome in the output line item? For example Input 1 is 31.49500 - how do you want to see these numbers in the output line item - 31.495 or 31.5 or any other specific way




  • @Misbah I just what it to be consistent so either both 31.49 or 31.50. Reason i say this is because we have tried few things like replacing 100 with 10 in rounding formula but it works for some scenarios and breaks for others . Unable to get a consistent result with rounding function 

  • @karank 


    Can you try this and see if this helps


    Remove Round Function from the formula and  - and keep your decimal places in the output line item to 2 or 3 whatever your requirement is


    For example in my case I have kept the setting as as 4 Minimum significant digits & 2 Decimal places. I am getting the desired result because Anaplan automatically rounds it if you keep lesser decimal places than the input line item.


    See Screenshots in attachments




  • @Misbah This approach works for display only . However when you extract data it extracts all digits in csv. 



  • Maybe it's because of formating it's not showing desired results
  • Hi,


    Round is known to have an issue as found in this topic. Your is different but might be related to the underlying engine as well.

    I tried to reproduce it as well but I couldn't. My module rightly display 32.49000

    Have you raised this case to support ? It would be interesting for us to be able copy copy this model to be analyzed.



  • @nathan_rudman

    yes i have now . Support has acknowledged this as a bug .
  • Hi 


    @stephen.brook Exact solved this issue