Odd Division Output


Would someone explain why Anaplan is giving me a number 5x larger than the number I am dividing when my calculation takes the first number (4,221.43) and divides it by 0? I would assume that it would be 0 or a NaN. Not something as large as the last number.

incorrect calc1.JPGincorrect calc2.JPG

Best Answer

  • DavidSmith


    Definitely a little odd

    If you round the source (in the source module), do you still get the same result

    I think it looks like you are using ratio as the summary method. I wonder if that is the cause

    Is the result odd for detailed members and/or totalsl?



  • Hi,


    have you checked that the amount is not displayed as 0 because of the line item format but it has some decimals hidden? If it is an unexpected amount because of an allocation you can use the ROUND function.




  • Hey @a.dilieto ,


    It looks to be a true zero and not a decimal. Is this a common thing in Anaplan?


    true 0.JPG

  • @dgregs, then It is not a normal behavior: could you post the formulas and blueprint?




  • Here is an export of the blueprint. The item we are looking at that is off is the budget per tx line item and the line item subset we are looking at is 6603. Since that is not an exception in the formula then the calculation is just taking the budget(4221.43)/budgeted tx (0).

  • @DavidSmith 


    It looks like the round formula worked when I added it to the source. The totals in the hierarchy are functioning as you would expect, it is just this one case. Could you explain why something that is showing as a true 0 would be causing this issue, but when the round function is applied Anaplan starts to treat it like a 0?

  • @dgregs 


    Glad it worked,. but no, this is not normal behaviour.  

    It's probably best to log a support call


    They will want to try and re-create it, so if you can simplify the example, that will help


  • I tried to reproduce this, but could not. But i observed the decimals are not handled well when it becomes too small. Look at the summary for B in the grid and its actual value on the top right corner, i dont understand why Anaplan put 1 at the last decimal.image.png

    And here, everything is correct..





  • This is odd. I will try and log it with Support.

  • The denominator is obviously calculating as 0.00001, but it is showing as 0.0, so I think it is definitely a bug in there somewhere


  • Moreover, Anything/0 should not be 0, should be NaN.