Is Something Wrong With my Role List? Level 1




So while trying to update my Emp02 Employee Expenses module calculations for bonus, car costs, phone costs and medical costs to reference Emp03 Employee Drivers by Role module, I get this error: 


"Invalid error for 'EMP02 Employee Expenses'.Bonus: Automatic sum of 'EMP03 Employee Drivers by Role'.Bonus % over Role Hierarchy is not possible as Role does not have a built-in top level"


I'm guessing the issue stems from my Role list configuration because from my General list pane, my Role list doesn't have any text in the top-level box or in the parent box. What could I be doing wrong? 

I attached a picture of the error message. 


  • @sosunkwo 

    Not sure what you're looking at there or what your loading but I think you're close to the answer.

    Can you refer to the instructions when you were first asked to build the role list - also check data hub and spoke application?

    If the list is in the data hub the list should be flat.

    In your spoke application you may need to add a top level.

  • @JaredDolich, I'm curious as to why I'm getting the error message described in my first post. 

  • @sosunkwo ,


    In order to do a sum, the list must have a Parent member or Top level defined, this is why you are getting that error.  To fix this, in the Roles list, you can put in All Roles as the Top Level item.



  • @sosunkwo 

    Because the file you loaded included a "Parent" column. Since there's no parent (top level, in this case) you will get the error.

    Your choices are to add a top level that matches the parent value in your input file or don't load the parent column.

    Either of those will clear up your error!


    Let me know what you end up doing. Just curious.

  • @JaredDolich 


    Ok, so I'm trying to run the import for the role list again. My question now is how would I "not load the parent column."?  Pls see attachment. Thanks

  • @rob_marshall 


    So I tried typing in top level box, but it gave me this error. (attached)

  • @sosunkwo 

    You have a list item that has that name.

    Delete that out of your list first. Then add All Roles to the top level.

  • @JaredDolich 


    I want to make sure I understand you correctly. So delete where it says "All Roles" at the bottom of the Grid View of the Roles List? (Pls. see attachment)

  • What do you see in your "Role" list? Does it contain "Parent" and "Code"?




  • Based on your image, I see that the Parent column in empty. I would just add "All Roles" to the Parent field for all the line items.

  • @AashcaJ 


    I actually just took that out now to see if it would clear things up. It has been there previously. Either way I still get the error message in my initial post. (pls see image)

  • One more thing I would mentioned is to make sure that your "Configure" tab looks like the one I attached. I see your list and I don't see a roll up.03032020.JPG

  • @AashcaJ 


    Tried that too, I got this error message: 


    'All Roles' is not valid for the name of the top level item of Role. 'All Roles' clashes with the name of an existing List Member. 


    However, no other list goes by the name "All Roles", so I'm confused as to where the 'clashing' is happening. 

  • This seems like a real tricky rabbit hole to send users down, and prone to frustrating them in completion of their certification. To wind up at this error you have to have (successfully, as far as you can tell) upload the source CSV for Roles, then Build EMP03 Module, then import data into SYS08 list, then when you go to change the formula you find this error. So you have to go back and undo the last two things you built, then go into the source file CSV, delete the Parent column entirely, re-upload that, go into the configuration of the list (not covered in any training video that I could find), add in the new top level, re-build EMP03 module, re-import data into SYS08 list, then you go to change the formula yet again, you now get the attached error. 

  • @sosunkwo 


    Figured it out with some help from @ChrisMullen - the issue is that you have to go into the SYS08 module and change the time scale manually from Month to Not Applicable (since you build the EMP03 module without time as a dimension). See attached screen shot - all you have to do is copy the "Not Applicable" in the first row to all of the other rows in the module. The little pivot table icon in the first column next to the row title is an indicator that something is off dimensionality-wise. Once you've fixed this you should be able to re-import your employee data and then proceed with updating your formulas for the new drivers / roles. Hope this helps!

  • Hey members, so I've been carefully following this thread as had a couple of already mentioned issues, tried to fix everything and was able to make the model accept the new formula on EMP02 with reference from the Roles drivers in EMP03 using IF Employed? THEN 'EMP03 Employee Drivers'.Medical Benefit[LOOKUP: 'SYS08 Employee Details'.Department, LOOKUP: 'SYS08 Employee Details'.Role] ELSE 0, however the result that I get from Medical Cost does not seem to be right as per the Module Certification question number 4. 


    Wondering what else can I do? 


    Does it look as the issue comes from the list? (meaning first step)


    Note: Not looking for answer, just some extra guidance. 

  • Wont it be non applicable anyway? Since its a system module and there is no need for time dimension. Even during module creation activity for SYS08 they mentioned to just take one employee dimension.


    Unless I'm missing something here..

  • Hi @sosunkwo - I have been stuck on the exact same problem you had "Role List Problem" And can't seem to find an answer anywhere. Did you ever get to find a workaround for this? Thank you in advance! 

  • @CommunityMember127535 can you share screenshot and the problem/error you are facing, I can try to help..

  • Thank you @SatyamArora Please see more detailed info below as well as an screenshot. 


    Original Formula:

    IF Employed? THEN Salary * 'EMP01 Employee Drivers'.Bonus %[LOOKUP: 'SYS08 Employee Details'.Department, LOOKUP: 'SYS08 Employee Details'.Country] ELSE 0


    New Formula: 

    IF Employed? THEN Salary * 'EMP03 Employee Drivers by Role'.Bonus % [LOOKUP: 'SYS08 Employee Details'.Department, LOOKUP: 'SYS08 Employee Details'.Role] ELSE 0


    When I enter the new formula the attached Error Pops up. 

  • Try to think which all line items do you need to apply this formula to, is it asking you to lookup specific .... related to employees

  • Hi, @CommunityMember127535 , let me know if you figured it out from others' response. If not, I'd be happy to help. 

  • Hi! I was actually able to solve with some help from the Community. Thank you anyways!
  • Hi, @CommunityMember127535

    Happy to hear that! Cheers.
  • Can you please share the solution even I am facing same issue

  • Hey All,

    I ran into a bit of trouble, and while there was some help on this thread, I just wanted to add that you should check the Data Type of the Role (and Region for me) in your modules; make sure they are formatted as a LIST and not as TEXT ; then, you might need to re-import the data after refomattting the data types.

  • Update the LOOKUP function to reference a line item in the employee property module which is formated as the Role list.

    If you have this as Text then you can use FINDITEM to convert this to a list format in a second line item. The line item must be LIST formatted. 

    The error is presented as Anaplan is attempting to map the data in the source to dimensions in the target. If any differences are not mapped then it will attempt to take data from the top level by default. If there is not a top level and you haven't used a mapping you will get this error.

  • I have exactly the same problem, actually I have no idea how to fix it!

  • Hi Guys, 

    In response to the original problem of this thread regarding the "All Roles" list not being able to be set as the Top Level Item I HAVE WORKED IT OUT. Go into your Roles list - Press Configure - Change the Parent Hierarchy to the Roles List - Go back to Tree View - (you will notice 'All Roles' is no longer in any hierarchy roll up) - Delete 'All roles' in this tree view list - go back to Configure - Type in top level item "All Roles". Done, the new Role List now has a top level item called All Roles and when you go back to Tree View you will see it reappear in proper Hierarchy roll up.


    Hope this helps,

    However I am still finding a problem with formula giving a new Error 


    "Format of mapping used for lookup doesn't match any dimension of the source"


    My formula entered is 

    IF Employed? THEN Salary * 'EMP03 Employee Drivers by Role'.Bonus %[LOOKUP: 'SYS08 Employee Details'.Department, LOOKUP: 'SYS08 Employee Details'.Country] ELSE 0
    Any help would be appreciated. 
  • This is my formula:


        Salary * 'EMP03 Employee Drivers by Role'.Bonus %[LOOKUP: 'SYS08 Employee Details'.Department, LOOKUP: 'SYS08 Employee Details'.Role]
    It was to do with Role configuration only. I just removed All Roles in Configure tab and updated it again. Somehow it worked now.