'Upload File Not Available' Errors / Default File Setting for Deployed Models


We have occasionally experienced failures in import actions (on deployed models) called via Anaplan Connect with the error ‘Upload file no longer available’. Our understanding is the default file should to be specified as ‘admin’ instead of ‘private’. This setting can’t be changed via API call, so we updated the mappings in our dev model. When we attempted to sync the updated dev model with an existing QA model, the change in default is not recognized as a structural change.  When we created a new QA model by copying or importing the dev model, the default file setting on our import mappings reverted to ‘private’. And we can’t update the default file in the QA model without taking it out of deployment mode, which would break compatibility between the dev and QA models.


How can we best avoid ‘Upload file no longer available’ errors on models in deployment mode?


Best Answer

  • kavinkumar
    Answer ✓

    HI @CommunityMember116379,

    Let me put my thoughts on this. 

    The error which you are facing is something that you would want to correct in Anaplan. So before we step in let's understand how Anaplan connect works.

    When you try to run an import file action through scripts, first the file will be loaded into the Anaplan Cloud server (You can see the latest data in the Import Data sources tab for that file) then the import action will be run which will upload the latest data into the system. 

    Now the issue could be because of

    1. The source file name (Check the source file name in Anaplan connect). 

    2.  Make sure that the source file which is getting updated through Anaplan Connect is being used for the import action (Check the Source label for that import action).

    3. Do the one-time activity of 'Manage Import Data Source' with the original file name and the structure.

    By doing all the above activity, you should be able to overcome the issue and run the import action successfully.

    I hope this helps!


  • Setting a default file is not a structural modification of the model - it's just file content that would normally be private to you becoming the default copy for when no private copy is available. As such you should still be able to set it even when the model is in deployed mode.

  • Panji



    i think you need to make  action process to production data, and you just need to re-upload file with the same name in source label in the  production model and then you can re-run your anaplan connect,


    if you set default to "Admin",  the file import will be the same all the time, so when you run anaplan connect and have new data, the data will note to be imported because anaplan will read same data.





  • Thank you for the detailed suggestions! I think the step I was missing was the one-time 'Manage Import Data Sources'



    Drew Paradine