Error in Formula in Rep quota module

Hi , Can any one please help me with the following formulas used in Rep Quota Moduel: Tenure Formula: IF NOT Active? THEN 0 ELSE IF YEAR(START()) ‐ YEAR(REPSETUP.Start Date) = 0 THEN MONTH(START()) ‐ MONTH(REPSETUP.Start Date) + 1 ELSE 12 ‐ MONTH(REP SETUP.Start Date) + (YEAR(START()) ‐ YEAR(REP SETUP.Start Date)) * 12‐ (12 ‐ MONTH(START())) + 1 Ramp Period : IF Active? THEN IF Tenure > 18 THEN Ramping Periods.'18' ELSE FINDITEM(Ramping Periods, Text Tenure) ELSE BLANK iam using the above mentioned formulas and getting an error message.

Best Answers

  • [quote=Pavan Bellemkonda]Tenure Formula:
    IF NOT Active? THEN 0 ELSE IF YEAR(START()) ‐ YEAR(REPSETUP.Start Date) = 0 THEN MONTH(START()) ‐ MONTH(REPSETUP.Start Date) + 1 ELSE 12 ‐ MONTH(REP SETUP.Start Date) + (YEAR(START()) ‐ YEAR(REP
    SETUP.Start Date)) * 12‐ (12 ‐ MONTH(START())) + 1

    Ramp Period :
    IF Active? THEN IF Tenure > 18 THEN
    Ramping Periods.'18' ELSE
    FINDITEM(Ramping Periods, Text
    Tenure) ELSE BLANK[/quote]The error might just be because 'Active?' needs to be in single quotes because it contains a question mark. 
  • Some questions then:
    Are both formulas giving you error messages? Or is only one of the formulas giving you an error? 
    The first formula, for Tenure, looks fine to me. If that is erroring, can you check the dimensionality and formatting of 'REPSETUP.StartDate' - based on this, it should have all the same dimensions and be formatted as a date.

    Is there any information in the error message?

    What lists do you have applying to each of the line items where you are putting these formulas?

    The Ramp Period formula also looks fine. If you delete the formula from Tenure, does the Ramp Period formula work? Is the Ramp Period line item formatted using the Ramping Periods list?

Comments