not recognised as a hierarchy



Hi getting below message when I try to add formula to code as per 6.8.2 Activity .  



Best Answer

  • ArunManickam



    Do not type the list name when editing the formula, goto General lists > click on the list name


    This should resolve it.





  • Hi Sam,

    Could you share a screenshot of all the lists in your model

  • Sam007_0-1599171288686.png

    Hope you can see this, thank you in advance

  • Thanks Arun,


    Will try this.

  • Avoid those special characters on list names, module names and line item names.




  • The Solution of just clicking from General Lists did not work for me! (I think because I am using the newer interface)

    However, it pointed me in the right direction.

    I started by copying/typing and pasting the whole formula including G3 Locations in the edit section that opens when you click on the double chevrons.> Then I went to general lists > double clicked on G3 Locations (it turns blue and editable)> I then highlighted and copied the blue text version of G3 Locations> Then highlighted G3 Locations part that I had originally typed/pasted and pasted what I copied from the general lists to replace it. 

    It looks identical, spacing and everything was the same but it worked


    This SOLVED it for me. Hope this helps the next person not waste as much time as me!