Line items are blank on Export

jamesreedehit
New Contributor

Line items are blank on Export

I have an action available on a dashboard that runs an export of a module that is displayed on the same dashboard. Currently when I run the action with Profile A the export file is populated as expected. When I I run action with Profile B the export file has only the line item headers and no data. I can't figure out what the access issue is because both profiles can view the data in the table on the dashboard and can view the data in the module. Also if Profile B runs an export from the table on the dashboard the export file is populated as expected.  I've checked access to all the relevant Actions, Lists, and Modules. Can anyone help me understand what's going on with the export?

 

1 ACCEPTED SOLUTION

Accepted Solutions
jamesreedehit
New Contributor

Re: Line items are blank on Export

Thanks for the replies on this. The dashboard did have filters applied from another module. Thanks for the tip to check that.  I checked and verified that both profiles had access to the modules used for filtering. I'm not sure what was going on with the export. I ended up creating a new export and it works for both profiles. 

View solution in original post

3 REPLIES 3
LipChean_Soh
Certified Master Anaplanner

Re: Line items are blank on Export

Hi @jamesreedehit 

 

What does Profile A and Profile B mean?

 

How does Profile A run the action? Is it via an action button on the dashboard? And is the export file in a csv/xls/xlsx format?

 

You also mentioned 'Also if Profile B runs an export from the table on the dashboard the export file is populated as expected.' How is this executed?

 

It would be good if you can add relevant screen shots here.

 

Thanks,

LipChean

kevin.cho
Certified Master Anaplanner

Re: Line items are blank on Export

One thing to check would be access to any filtering modules that you may be using. 

 

When you initially created the export action, did you apply any filters (from a different module) to the module? 

 

Does Profile B have access to the modules where the filters are sourced?

jamesreedehit
New Contributor

Re: Line items are blank on Export

Thanks for the replies on this. The dashboard did have filters applied from another module. Thanks for the tip to check that.  I checked and verified that both profiles had access to the modules used for filtering. I'm not sure what was going on with the export. I ended up creating a new export and it works for both profiles. 

View solution in original post