SYS14 Create Account>Product, Line Item "Data?" can't refer SYS12 and SYS13

ssicefox
Frequent Contributor

SYS14 Create Account>Product, Line Item "Data?" can't refer SYS12 and SYS13

I've create on Data Hub the module SYS14 Create Account>Product and looks like:

 

ssicefox_0-1629463729223.png

 

 

But I am blocked by 

Data?(Boolean) filter to determine if ANY data for product SKU under the product 

  • If you are using the Level 2 Data Hub model: reference the SYS12 SKU Details and SYS13 Account SKU filter.
  • If you downloaded a new Data Hub model at the beginning of Level 3: Use a formula that references entire timescale of the DAT05 Historic Revenue by Product module to filter for revenue greater than 0.

 

I tried to refer the SYS12 SKU Details and SYS13 Account SKU Filter, but I am not successful. So I used the second method in my Level 2 Data Hub model using a formula TIMESUM('DAT05 Historic Revenue by Product'.Revenue) > 0, then the SYS14 looks like:

 

ssicefox_1-1629465759824.png

 

Could you confirm that we can have the same results with two approaches?

 

I am looking forward to hearing from you soon.

Best regards.

1 ACCEPTED SOLUTION

Accepted Solutions
Misbah
Moderator

@ssicefox 

 

Yes both gives you the same results. I personally have taken the second route.

 

Misbah

View solution in original post

3 REPLIES 3
Misbah
Moderator

@ssicefox 

 

Yes both gives you the same results. I personally have taken the second route.

 

Misbah

ssicefox
Frequent Contributor

@Misbah,
Thank you for your reply.
Thank you for sharing your experience. 🙂
ParidhiRai
New Contributor

Hi,

My reply has nothing to do with what was asked originally because I see that has been answered already.

 

However, just a note:

 

According to the instructions the "Code" column is supposed to be populated only when the "Valid?" Boolean is checked, I see here that the "Code" column is populated irrespective of that condition. This would affect the build later on.