User Access Between Schedules and Snapshots

edited March 2023 in Modeling

I have a user who has access to schedules but doesn't seem to have access to the corresponding Snapshots. A few things I have tried so far, are:

1.) Confirm their role and that they have access to the schedules

2.) Used my account as a test account to recreate the issue. When I tried to recreate the issue, I was able to see all of the snapshots.

I believe it is a User access issue, but can someone point me in some directions on what the cause of this could be and solutions? I've attached screenshots for reference as well.


  • It will be hard to answer without seeing any of your list structures or any details about how your roles are set up. It's also not clear what exactly this user is not able to see (i.e. can they see the page? can they see rows? can they see cell data?).

    I suggest double checking all the access settings for the role in question:

    You should also review any Selective Access or Dynamic Cell Access if you have those turned on.

  • @ryan_kohn Thanks for your feedback! If you look at the first screenshot, they are not able to see no Snapshots at all. In the second screenshot, I used my account to test access to recreate the issue, but I was able to see everything.

  • Okay, I'm following now — this user is not able to see those pages.

    In your first screenshot, the section is collapsed (the arrow on the left looks like “>”, whereas if the section was expanded, it would look like “V”). It's worth confirming that that is not the issue. They can just click on the arrow or the section header to expand the section.

    As a next step, you will need to validate the page access settings:

    Finally, note that the user also needs access to the underlying model in order to see the associated pages.

  • @ryan_kohn In the video the user sent, they did show where they collapsed and expanded that section and it was completely empty. But I will need to follow back up with you once I validate the page access settings. Definitely appreciate your help!

  • chp127

    Hi @wbroughton ,

    Please check below user access.

    1. check what is source model mapped with page and if user have have access to model or not.
    2. check in page setting , page access restricted for specific role. If yes then add user role in page restriction.