Import action should not ignore Selective Access for a Workspace Administrator


Description of the enhancement required:

Workspace admin with applied selective access to only one region had affected data in other regions because selective access does not work on Workspace admins.


An example of the enhancement:
As a workspace admin if I change my profile to only have access to a specific region, and then run an import, it clears the data for all regions but imports the data for only the region I have access to. It would be better if it either
1) (ideally) both cleared the data for the region I have selected and imported the data for the region I have selected
2) or both cleared the data for all regions (overriding the security settings) and imported the data for all regions (for the region I have selected)


How would it help your business process:
We may have people working in the model that are workspace admins alongside non-workspace admins. Other people working on their list would be confused to why their data was being modified.

51 votes

In Review · Last Updated


  • Status changed to: In Review
  • Miran
    Status changed to: In Review
  • Especially when you want to do testing of DCA, have to turn off the WA and then have it turned back on again. Very frustrating.

  • Miran

    Hi @andrewtye, are you looking to merge the two ideas? Thanks. 

  • Hi @Miran - yes because they read very similarly albeit this one is slightly more wide ranging than the other ie takes into account user role/.

  • Miran

    Hi @andrewtye, I've gone ahead and merged the ideas and kudos. 

  • Just had this issue and wondered how it had happened...

    I would like this change applied so selective access is effective on Actions.

Get Started with Idea Exchange

See our Submission Guidelines and Idea Evaluation Criteria, then start posting your own ideas and showing support for others!