Ignore Timescale as a dimension if Time formatted mapping line item is used for aggregation


I ran into the issue when I needed to pull the data from the module with a timescale as a one of dimensions to another module that also contains timescale as dimension. I used time formatted line item in the source module for aggregation but it's been ignored in the Result module and error message box has been appeared.




Source Module                  
Timescale / Line Items FY10 FY11 FY12 FY13 FY14 FY15 FY16 FY17 FY18
Value 1 2 3 4 5 6 7 8 9
Mapping Item FY20     FY23     FY19    
Result Module                  
Timescale / Line Items FY19 FY20 FY21 FY22 FY23 FY24 FY25 FY26 FY27
Expected Value 7 1     4        

When I set a formula for Expected Value = Source Module.Value[sum:Mapping Item] Anaplan shows "An error has occurred on the server. The model has been restored to its state prior to the last submission."


In order to avoid that I need to create intermediate line items with excessive dimensions. It consumes space and isn't efficient. 


It would be very helpful to add ability to aggregate the data using Time Formatted Line item.

34 votes

In Review · Last Updated


  • Agreed, we should be able to SUM from a module with time.

    You may already be doing this, but the best workaround is to use a line item dimensioned by a fake time list - Sum the data into that line item, and then pull the data into the previous target module 


  • Miran
    Status changed to: In Review
  • Fased the same issue - need to SUM by time dimension to finish one big development. I didn't expect that it can't be done without using excessive dimensions. Can I hope this problem will be solved in nearest future? Can I get a message when this functionality will be improved? 

  • Status changed to: In Review
  • Hi, 


    I encountered the same issue and I noticed that it appears only when the source module has in its structure the Time scale. 


    If the source module has in the structure the Time scale dimension and the target module structure is not matching with the Time scale from the source module (same level and/or range elements) then you are in trouble.


    I tried to replicate the error from the first post and I received the error only when in the target module range were present also the years from the source module.  

    If the target module is setup a range only with the target years ( only FY19 to FY26) is not returned any error.

    However, the result in the target module was zero value... 


    A workaround was indeed to use in the source module a normal list (Dummy Year).


    It would be really helpful if Time scale dimension would have the same behavior as the normal lists. 🙂 





  • This change should be on the roadmap, it is not consistent that you cannot sum over a timescale. Because you can't do this we are having to develop inefficient work-arounds to manage what should be a fairly standard set of functionality.

  • +1, experiencing the same issue.

Get Started with Idea Exchange

See our Submission Guidelines and Idea Evaluation Criteria, then start posting your own ideas and showing support for others!