Anaplan Connect 1.4 not detecting Java executable (Java binary at path does not exist)


Hi there,


I am looking at updating from Anaplan Connect 1.3 to 1.4 but I'm having an issue with the .bat file not finding the java executable.

1.3 detects it without any change needed to the .bat file, but I have set the Java variable in the .bat file to the location of the JRE as well as setting the JAVA_HOME environment variable as well. This is the JRE location that is being used by 1.3 without issue.

The error returned is "Java binary at path does not exist". Has anyone else seen this error?




  • Hello Jones,


    It might help if you can copy and paste the Java variable you have defined in your script. I've seen this issue in the past where the Java variable might need to be defined without quotes. Here is an example:


    set JAVA=C:\Program Files\Java\jre1.8.0_231\bin\java.exe





  • Hey Jones,


    I am using jdk-11.0.5 and I have tried setting JAVA_HOME variable value as C:\Program Files\Java\jdk-11.0.5\

    It worked for me.




  • Nivetha

    Hi Jones,


    This error "Java Binary at Path does not exist" usually comes when you have not provided the exact location of JDK from your local system. It doesn't matter which version of Anaplan connect you use(Either Anaplan connect 1.4.3 or 1.4.4). You must always give the path of JDK instead of JRE in the environment variable path. 


    To resolve the issue, 

    Environment variable: JAVA_HOME

    Path: location of your JDK path from your local system.



    Nivetha K