Anaplan Connect Batch File - Windows Task Scheduler


Hi team,


I have Anaplan Connect batch file which runs an Export process that runs perfectly when executed manually (double clicking on the Batch file) but when I run the Batch file through Windows Task Scheduler I receive the below error


Any ideas?





Best Answer

  • MarkTurkenburg_*8288

    The issue was the directory in the 'Start In (Optional)' box does not have " " around the location


    Once I removed the " " it worked fine



  • @MarkTurkenburg 

    Seems like windows scheduler cant locate your batch script . Try one of the following 


    1. Give the full path for the script so something like "C:\User\Script Folder\Script.bat" or 
    2. Specify "Start in" location (this is where script is located C:\User\Script Folder)  and in program Script specify script name ( Script.bat) when scheduling task in windows task scheduler .  
  • Thanks for the reply @karank 


    I've put the below in the boxes but it is now not even running in Scheduler 


    Program/Script: "Q:\02 Financial\1. FPANDA\anaplan-connect-1.4.2\anaplan-connect\Whispir Actuals - Process Export.bat"

    Start in (Optional) "Q:\02 Financial\1. FPANDA\anaplan-connect-1.4.2\"


    Any other ideas?





  • it is EITHER OR not both options at the same time 


    so if you are going option 1 don't do option 2 and vice versa


  • It is not EITHER OR


    The 'Program/Script' box is mandatory which is what I already had


    I added the 'Start in (Optional)' box but then it stopped working altogether 



  • Its Either OR based on my response  I mean ( i provided 2 options ) 


    you don't need start in location if you are specifying full path (this was option 1)


    If you are specifying start in position then you must specify script name ( this was option 2)

  • Thanks @karank 


    So the issue was that I needed to have both the Full Path & the Start In location (I think this is because you need to run Anaplan Connect where the API is saved)


    But the start in location is entered without the " " which is confusing (most directory entries in all programs are entered using " ")