ALM Error

sarah.esguerra
Contributor

ALM Error

Hi, would like to ask how and where is this error coming from?

Our test model is not in a deployed mode, and we uploaded data/lists directly in the test models. Then afterwards, we tried to synch the changes in Dev to the test model but this error occurred. Thank you.

MicrosoftTeams-image.png

2 REPLIES 2
Misbah
Moderator

Re: ALM Error

@sarah.esguerra 

 

In the Test Model If the lists (which you uploaded) were marked as Production Lists before the upload then this error shouldn't have come but if that is not the case then this change is considered to be the structural change which basically means that your Test Model is not compatible with  Dev model anymore.

 

What you can do now is that You can go to the test model -> Revision Tags-> Create Model from Latest Revision and create a new Dev Model.

 

Misbah

alexpavel
Certified Master Anaplanner

Re: ALM Error

@sarah.esguerra ALM works in a linear way and if the Target model (Test) is not in Deployed mode and you do modifications and want to move back in DEV these modifications, it is not possible if in DEV were made in the meantime other modifications. 

 

However, it is quite a strange error: if this would be the case, the ALM should not even arrive to have the possibility to choose as source the Test model for DEV. 

 

If you plan to do modifications in the TEST model, I would strongly advise putting the DEV model in Deployed mode..this way the DEV model is protected against any structural modifications. 

 

In order to solve the current situation:

1. archive the current DEV model

2. create a copy model from Test model and the new copy can become the new DEV. Just be aware to change and re-setup the source models (if the model is part of multi-model Connected Planning). 

 

Hope it helps

Alex