Change to User SSO Flag/API Connection?

Highlighted
Certified Master Anaplanner

Change to User SSO Flag/API Connection?

Have there been any recent changes to the API or user access that would affect how our data integrations work?  We currently have some cases where we have set up a connection from Anaplan to Alteryx using Basic Authentication.  Over the weekend, something seems to have changed in the connection where the user account we were using (which has been flagged as an SSO user since May) must be marked as an Exception user in order for the connection to work.  Have any other customers reported a similar issue?

 

Although I understand that Anaplan recommends that there be at least one admin user per customer who is flagged as an Exception user, this does not sit well with our internal INFOSEC group.

5 REPLIES 5
Highlighted
Master Anaplanner/Community Boss

Re: Change to User SSO Flag/API Connection?

Hi rupadhyay72,

If I'm not mistaken, an exception user was always required for integrations. This was not a recent change
We have been promised SSO level auth for integration in an upcoming update

Hope this helps

Regards.
Anirudh
Highlighted
Certified Master Anaplanner

Re: Change to User SSO Flag/API Connection?

@anirudh 

 

I have to respectfully disagree as this has been working on a daily basis, with the integration account flagged as an SSO user since May, until last Friday.  We opened a case with Anaplan Support, and their response so far is to conclude that there was a "change in behavior that may have been caused by the recent release over the past weekend."  We are still waiting on a further update from them.

 

Highlighted
Master Anaplanner/Community Boss

Re: Change to User SSO Flag/API Connection?

@rupadhyay72 

 

Don't know what's going on. Many of my colleagues raised this similar query. Found this thread which explains why some fail and why others pass

Solved: Anaplan REST API with Cert Access: Connect to dif... - Page 2 - Anaplan Community

 

 Below Screenshot is the gist of this thread.Misbah_0-1597211733288.png

Your case seems to be different. I wish I had a better answer.

Misbah

Highlighted
Certified Master Anaplanner

Re: Change to User SSO Flag/API Connection?

 

@Misbah 


Thank you for this information; this was extremely helpful for multiple reasons. Although our case is a little bit different, I can see the similarities in here to what we are experiencing.  In addition, we are now working on a project where our Data Hub is in a separate workspace from the Target model, so it is good to have this information for that project.

 

Thanks again!

Highlighted
Master Anaplanner/Community Boss

Re: Change to User SSO Flag/API Connection?

We had the exact same thing and had this response:

"The platform upgrade which took place last weekend (8th Aug) has introduced a change which now means users who are sending API requests must be marked as Exception users in the workspace (SSO unchecked). As I understand, this change was not intended to be made without prior communication to customers, however it was inadvertently introduced as part of a fix for a particular bug. "

 

Quite which of the bugs from here https://community.anaplan.com/t5/Releases/What-s-New-August-8-2020/ba-p/79790 it fixed i'm unsure.