Import for Weekly Data


I am trying to import Historical Weekly Data, but am constantly getting error.

Please assist how to import Weekly Data?


I tried several times, I have attached Screenshot.



Best Answers

  • Misbah
    Answer ✓



    Can you please map it like below

    Column 3 : Weeks - Time

    Column 2 : Accounts - Accounts Flat

    Column 1 : SKU - SKU Flat

    Column Headers -  DAT03 Historic Volumes Line Items


    Last mapping you are doing it incorrectly as you are mapping it the Column 4: Volume


    Hope that helps


  • kavinkumar

    HI @Sravan_Kumar,

    The issue is not with the time dimension. The error says that the mapping you made to the line items is wrong. 

    Based on the mapping, the system will read each value in the 'Volume' column and try to map it with the line items present in the target modules. Fr ex, Anaplan try to find a line item with the name 58.87728739 as per 1st record. But this should be the case. 

    My understanding is, you are trying to import the volume data at  Acct, SKU and Weekly level. Please do the mapping correctly. 

    If there is only one data that needs to be imported, then make use of the option 'Fixed Line item' else 'Column header' as per @Misbah post.

    To help, please find below,


    Column 3: WeekTime   
    Column 1: SKUAccount Flat list   
    Column 2: AccountSKU Flat list   
    Fixed line itemDat03 history volumes line item Data Values from 

    Column 4: Volume


    And finally in the line items tab (last tab), mark the destination line item.




    I hope you understand!! Let me know in case of any concerns.



  • matt_m-p
    Answer ✓

    Hi @Sravan_Kumar,


    Thank you for your post. 


    I can understand how this issue can be frustrating. 


    For your Source, if you have

    "Week" => to Time

    "SKU" => to SKU Flat

    "Account" => to Account Flat

    Fixed line Item => to DAT03 


    You are good.  


    It is when you are under the "Time" tab that the issue may arise.


    You need to select the Match names option in the "How to map the source data into the timescale" section.  This is because Anaplan is reading Week 1 FY19, Week 2 FY19, and so on as specific names not as units of time.


    I hope this helps.