Trying to use ALM when Write access driver exists




I get the following error when I try to use ALM, and have   a write access driver.
"An internal error occurred while preparing the structural changes for synchronization. Reason for error: To serve as an access driver, a line item must be formatted as a Boolean."


For my write access driver, i do have a booelan list, where users can select which entities to exclude, and this gets applied to a calculation.


how do i get round this issue?


  • @alismith 


    I have faced the same issue earlier and this error occurred for line item that is driven by DCA.

    Quick way to find out all the line item which having DCA, Go to Setting -> Module -> Line item -> Read & Write Access Driver. Here you can export the blueprint for all the line item for your reference.


    Please follow the below steps for the workaround for the line item that is driven by DCA.

    1. Remove the access driver

    2.Create a revision tag and sync

    3.Re-add the access driver

    4.Create a revision tag and sync


    Hope this helps




  • @alismith 

    @Akhtar.shahbaz is right and the reference is to a known issue.


    However, I use DCA on ALM all the time and I've never had this problem.

    I'm going to try to replicate the issue because it seems odd that there's a condition that doesn't cause this error.

    Only thing I can think of off the top of my head is a security issue but that seems like a stretch. Is the ID that is using ALM have full access rights?

  • @JaredDolich ,


    I think the issue is occurs when a line item is created, uses DCA, and then is sync'd.  The problem is an order of operations issue in I think the line is sync'd in Prod first, but has an issue as the DCA Read/Write line item hasn't been created yet.  This is. why. @Akhtar.shahbaz solution should work.



  • @rob_marshall 

    Really glad you mentioned that - I'm trying to replicate that issue.

    Just so I'm clear, the workaround is that you have to get the line item created in production first before you can apply DCA?

    Odd because I just created a new line item that uses DCA in my dev model (both read and write) then sync'd it to my prod model and it worked fine.

    I also tried creating a new line item that uses a formula and DCA. No issue there either.

    So maybe I'm still a little confused what are the conditions that cause this to happen?


    In any event, glad there's a simple workaround. Good to know. 

    Thanks @rob_marshall 


  • @JaredDolich ,


    Yes, that is my understanding, if you create everything within the same sync it "could" have issues, I believe it depends with the order of operations.  So, say you SYS DCA module is created before the DCA Read/Write, you will not have an issue as it was already built in Prod.  But, say it is further down the list, then you could have issues.  Again, this is my assumption as I have seen this issue as well.



  • Thanks everyone,  that seems to work.


    I do have 2 models, connected to the dev model.  


    The first i did as explained.  remove the dca, sync, added it back and sync. and it worked.


    the 2nd i just went from an older revision, to the latest and it worked straight away.


  • This is a bug that we've had for a while and should be corrected soon:

    if you have a write access driver on a line item WITH a formula, ALM will bug.

    You should not need write access driver on formulas, you can remove them.

  • @Akhtar.shahbaz thank you!

    3 years later I'm running into the issue :)