User Roles not syncing


Hi All,


I'm recently facing issues where for some roles in the model, access to actions are not being properly moved from Dev to Prod model.


For example, If I give WRITE access to a Regional Manager role from some Approval Process(Having certain number of actions) in the Dev model and then move it PROD. Now if I check the same process in the PROD model, I get the message "You are not authorized to this action".


In the PROD model, if I check the access to the actions for Regional Manager role, I see that this role has not been configured to run the Approval Process even if its properly set up in the Dev model.


The only work around for now which I've found is that, first I have to remove access to all the actions in the Dev model for this role. Move this to PROD model then again provide access to all the actions and then again sync it to PROD.


Is anyone else facing this issue and what is the causing this issue.


Thanks in advance!!



  • @pshashank 


    No, it just works fine for me. I know you would have done your research Mr. Shashank but if you are able to run the action in Dev Model with the same access then it's a weird scenario.


    1. Check if proper access has been given on lists if the lists are selective access enabled and your actions do interact with the lists


    2. If you are not an admin in the Prod model (highly likely) can you ask someone to take your WS admin access away in the Dev model and mirror the role and see if you get the same error in Dev model. Or else ask someone from the team to test it who doesn't have WS admin access to the Dev model.


    Let us know about your findings


  • @Misbah 


    I've checked all the roles and ensured that list access is there. I've tested scenario for #2 as well. In this case I'm getting the same error.


    I'm facing the issue since last one month as this. The workaround that I am using is time consuming as we have to do multiples syncs from dev model to fix the issues. Plus now we have to check all the roles twice (one time in Dev and other in PROD post sync) which takes a lot time.



  • @pshashank 


    Better to raise a ticket with Anaplan L3 Support team. They are great folks, they will investigate in detail and share findings with us.

  • @Misbah Thank you for the inputs!