Add Test model to existing ALM


Good morning everyone,


We are currently in the process of adding a test environment in one of our Workspaces. The target model is already deployed, and an ALM between the development model and the production model is already in place.
However, we cannot simply duplicate our production model and integrate it into the ALM as a test environment.
Since the data is relatively sensitive, I am coming to you to find out how to proceed in this particular case. Note also that we want to copy a "lighter" version than the existing production model, by reducing some dimensions.


Thank you in advance for your help




  • You can create an empty model from a revision tag and import partial data from a data hub or from dev.

    why can you not copy the prod ?
  • Misbah



    This can be done in two ways but here is what I think should be done


     1.Go to Revision Tags of your Prod Model and Click on "Create Model from Revision Tag". This will create a model without Production Data (meaning all the sensitive data that you have in the Production environment will not be copied). If there is any data that is sitting in structural lists should be wiped out manually in Test model

    2. Change the mappings in the "Source Model" section of the Test Model

    3. Load the Production data again in the Test Model.


    Note: Few things to note

    1.You may want to have a Test model which has close resemblance with Production data and not the distant resemblance.

    2. Keep the Test Model in its own workspace and don't put in Prod or Dev environment

    3. Keep the Test model in Deployed mode

    4. When pushing any change to Prod. Follow the approach 

           Dev->Prod & Dev-> Test and NOT Dev->Test->Prod


    Hope that helps



  • Thank you for your reply nathan_rudman.


    We are trying to copy a model M from the workspace A to the workspace B (the two workspaces belong to the same customer).

    As explained here, we're importing using "manage models" but once in Step 5, the only workspace that we can see is the Workspace B but what we need is the Workspace A to choose the model M. Do you know how to fix that ?


    Thank you in advance,


  • @Misbah  Thank you for your reply.

    Building a test model from the last Revision Tag of the prod model is not the best solution in our case since we have a lot of production Data and that we want the test model to be similar to the prod.

    The solution that we found is to copy the prod model, update some hierarchies and let some samples of Data and then Deploy it with the Dev model.


    As you said in the step2, we are now trying to copy the prod into another workspace but we still have a problem as explained in my previous post (my reply to @nathan_rudman). Do you know how to fix this issue ?

  • the only thing I can think of is access.
    Is one of the workspace SSO and not the other ?
    Try to make your user an SSO exception in both.
  • Misbah



    Can you confirm if you have both the workspaces are SSO enabled or both Non Enabled as @nathan_rudman suggested. 

  • VillardA

    @Misbah  @nathan_rudman 


    Thank you for your answers,


    Indeed, it seems that the SSO is implemented on Workspace B but not on Workspace A.
    In that case, what do you think is the optimal solution to solve our problem? Should we integrate an SSO system in Workspace A, or can we simply remove it from Workspace B?


    Thank you again for taking the time to help us,



  • it's ok for them to be on different settings.
    However the user doing the import/copy should access them the same way.
    Make your user a non sso user in both workspaces (you can do that in the user tab), reconnect and do the copy
  • VillardA

    Thank you for your response,


    We have now set the user rights so that they are identical for both workspace. However, we still cannot import a model from Workspace B to Workspace A and vice versa. The "Import" in "Manage models" only offers the models of its "local workspace". Both workspace are however on the same customer.

    Is it then impossible to copy the model that will allow us to set up our ALM? Do both have to be on the same workspace?


    Thank you for your help




  • jsut to confirm, you are no longer an SSO user on both ?
  • VillardA

    We have unchecked SSO for users on workspace B, and don't even have this option in workspace A (SSO is not set).

  • Misbah



    No, not at all. You should be able to import the model from different workspace if you have same SSO settings. Can you confirm if you are Importing into the Target Workspace picking up the models from Source workspace. Anaplan mostly work on the Pull Mechanism and not Push Mechanism

  • Also, as a note, when you try to import a model, at first, you should name the new model, and then should choose the option: "Anaplan/Production" and click okay.




    At this point, it will ask you what the Workspace is that you want to import from:



    And finally, once you specify the workspace, it will ask for a model.



    I am wondering if it is the first step of this operation that is causing confusion since it just lists "Anaplan/Production" even though this is the standard name that will always show up.




  • VillardA
    Thank you for your answer @jasonblinn 
    This process is the one we tried to follow based on the first answers we got.
    The problem is that, when selecting the Workspace, we cannot select Workspace B (which is associated with the same Customer).
    We have tried to follow exactly the steps you advise us to follow, but nothing works: we can't find the workspace.
    Do you have any idea where this problem might occur?
    Thank you in advance,