Adding to Numbered List using Create

Highlighted
Occasional Contributor

Adding to Numbered List using Create

Hi, 

 

I (full access user) have created a process where my data list is updated in the following way:

 

1) I created a numbered list (purely for the "create" function), and published a module referencing this list to a dashboard along with the create button. 

2) Users can then create new line items, fill in data, and run a second process which loads the data to the actual data list

3) the process is working perfectly in my QA model, but when I push to UAT, the process doesn't work. The message I get is "Sorry, you do not have permission to perform this action on the item(s) selected"

4) I don't think it's a role-related issue, as I am a full access workspace admin in both environments, there is no DCA involved, relevant lists have been made production lists, and it's not a synchronization issue. 

 

I can fix the issue by creating a permanent line item in the numbered "additions list" (ie: a line item that does not get deleted once the data is loaded), but I do not like how this looks, and I still do not know the root of this issue.

 

Any ideas? 

 

Thanks,

Andras 

11 REPLIES 11
Highlighted
Master Anaplanner/Community Boss

Re: Adding to Numbered List using Create

@atozser 

 

My First reaction to this would be to kindly check your access in UAT Environment. Although you have workspace admin access make sure that you have got all the required access on all the lists that have been marked as Selective Access Enabled. Basically copy the access into UAT environment and see if that works. When I say access I mean to say not only module level but also list, action, module and version level.

 

Kindly post the snapshot so that we can see what sort of error are you receiving.


Thanks,

Misbah

Highlighted
Master Anaplanner/Community Boss

Re: Adding to Numbered List using Create

@atozser ,

 

What you have done is correct, but sadly it is a bug in the system and has been reported.  Sadly, I do not have the information on when it will be fixed, but I am hoping very soon.

 

Sorry for the bad news,

 

Rob

Highlighted
Occasional Contributor

Re: Adding to Numbered List using Create

Thank you for the response. Do you know if it's because my UAT model is deployed? It is working perfectly in QA (not deployed). 

Highlighted
Master Anaplanner/Community Boss

Re: Adding to Numbered List using Create

@atozser ,

 

Yes, I believe it is the deployed bit that I think it messing it up.  Again, it is bug (currently) and should be fixed soon.  One thing to mitigate this, is to create a "dummy" member and make sure the user clicks on that first before adding the new member.

 

Rob

Highlighted
Occasional Contributor

Re: Adding to Numbered List using Create

I will do that - thanks for the help!

Highlighted
Certified Master Anaplanner

RRe: Adding to Numbered List using Create

Hey Rob,


Do you know the timeline on when this fix will take place?

Cheers,


Kevin

Highlighted
Master Anaplanner/Community Boss

Re: RRe: Adding to Numbered List using Create

@seemybeltz 

 

this should be fixed now, is it not?  If not, can you post some screenshots of it not working?

 

Thanks,

 

Rob

Highlighted
Certified Master Anaplanner

Re: RRe: Adding to Numbered List using Create

Seems like it's not fixed. At least when the parent is not a numbered list. Making the parent list numbered fixes the issue, but that might cause other issues... 

Kr,

Steven

Highlighted
New Contributor

Re: RRe: Adding to Numbered List using Create

I also experienced the same issue on my production model - anyone knows any workaround for this?

 

Thanks

 

Gwen