Current Period Change during ALM sync

Highlighted
Contributor

Current Period Change during ALM sync

Hi, 

I was syncing some changes from Prod to Dev and I realized the presence of some changes neither i did, nor did I find anyone else in history making it. Here is a screenshot from the comparison report:

ankit_cheeni_0-1597120228784.png

 

This seemed like an inconsequential change so I moved it to prod, later realizing that this changed the current period for the model. I don't understand the meaning of the screenshot or why would current period change due to sync. 

Can someone help me with this?

 

 

11 REPLIES 11
Highlighted
Master Anaplanner/Community Boss

Re: Current Period Change during ALM sync

Hi Ankit,

Looks like the labels for the time settings were changed. The quarter prefix and that half year prefix etc. When the label is changed, the change definitely shows up in history with the description "Change Time Scale"

ALM syncs do not affect the current period in the deployed model. The current period is production data

The 2 events are probably disconnected

Regards,
Anirudh

Highlighted
Contributor

Re: Current Period Change during ALM sync

@anirudh  That is my understanding as well that the changes shouldn't be connected. However, history report shows that this happened after I started syncing the changes and before I finished it which is peculiar since I can't make changes while syncing!

ankit_cheeni_0-1597121158313.png

 

Highlighted
Certified Master Anaplanner

Re: Current Period Change during ALM sync

Hi @ankit_cheeni 

This is interesting, but it seems like this might be part of the enhancement that was released this past weekend that allowed you to change the labeling of time periods. It looks like it went from being blank to having a pre-defined letter in there. I just ran the same simulation on a test model and got the same exact results.

 

 

Here is the information on the release. 

https://community.anaplan.com/t5/Releases/What-s-New-August-8-2020/ba-p/79790

 

Jason

Highlighted
Contributor

Re: Current Period Change during ALM sync

@jasonblinn this makes sense. I did not intentionally make any change to the time scale. Is it possible that Anaplan moved the changes by default?

Thanks!

Highlighted
Certified Master Anaplanner

Re: Current Period Change during ALM sync

@ankit_cheeni 

In my test, I also made no changes to the time scale, and saw the exact same notes in my comparison

 

jasonblinn_0-1597121433267.png

 

I have tried this in two separate test models and gotten the same results both times, so I have to believe that it is going to display this as a change the first time every model is sync'd following the release this past weekend.

 

I also ran a test to sync a second time, and did not get this listed as a change and it displayed as expected without this time change.

 

 

Highlighted
Master Anaplanner/Community Boss

Re: Current Period Change during ALM sync

Jason, did the current period change in the production model?

Thanks,
Anirudh
Highlighted
Certified Master Anaplanner

Re: Current Period Change during ALM sync

It did not. I made no changes made to the time scale in DEV or in PROD. 

Highlighted
Certified Master Anaplanner

Re: Current Period Change during ALM sync

@ankit_cheeni and @anirudh 

Looks like the current period might change with sync following the 8/8 Release.

 

https://community.anaplan.com/t5/Known-Issues-and-Workarounds/Current-Period-needs-to-be-re-set-for-...

 

I might have misspoke on my last point, but in my final test I did not have a current period set, so it did not change. Wanted to make sure to clear that up!

 

Jason

Highlighted
Master Anaplanner/Community Boss

Re: Current Period Change during ALM sync

Thanks Jason!

This is really good to know in advance

Regards,
Anirudh